Previous Page
Next Page

Key Terms

Exercises

1.1. Device Autoconfiguration

This exercise demonstrates three different methods that can be used to perform a reconfiguration boot so that the kernel recognizes new devices attached to the system.

Estimated time: 15 minutes

1.
From the OpenBoot prompt, type the following:

boot -r

The system performs a reconfiguration boot and a login prompt appears.

2.
Log in as root and create an empty file named /reconfigure as follows:

touch /reconfigure

Now reboot the system as follows:

/usr/sbin/shutdown -y -g0 -i6

The system performs a reconfiguration boot, and a login prompt appears.

3.
Log in as root and issue the following command:

reboot -- -r

The system performs a reconfiguration boot, and a login prompt appears.

1.2. Displaying Information About Devices

In this exercise, you'll use a few of the Solaris commands to display information about devices connected to your system.

Estimated time: 5 minutes

1.
Use the dmesg command to determine the mapping of an instance name to a physical device name. Type the following:

dmesg

In the output, identify the instance name assigned to each disk drive and peripheral attached to your system. On a system with IDE disks, you'll see entries similar to the following:

sd0 is /pci@1f,0/pci@1,1/ide@3/sd@2,0

On a system with SCSI disks, you'll see something like this:

sd17 is /pci@1f,0/pci@1/scsi@1,1/sd@1,0

2.
Use the prtconf command to see which drivers are attached to the instance names identified in the previous step.

For example, you should see an entry something like this:

sd, instance #0

1.3. Adding a New Device

In this exercise, you'll use the devfsadm command to add in a new device without rebooting the system.

Estimated time: 15 minutes

1.
Connect a tape drive, disk drive, or CD-ROM to the system and perform a reconfiguration reboot.

2.
Log in and issue the dmesg command to verify that the device has been installed. You should see an entry something like this if you're adding an SCSI disk drive:

sd17 is /pci@1f,0/pci@1/scsi@1,1/sd@1,0

Check to see that a driver is attached by issuing the prtconf command.

3.
Halt the system, turn off the new device, and boot the system back up using the boot command. Do not do a reconfiguration reboot.

4.
Issue the prtconf command. It should display (driver not attached) next to the instance device name for that device.

5.
Issue the devfsadm command.

6.
Issue the prtconf command again. The message (driver not attached) next to the instance device name should be gone and the device is now available for use.

1.4. Displaying Disk Configuration Information

In this exercise, you determine the disk geometry and slice information of your disk drive.

Estimated time: 20 minutes

1.
Log in as root.

2.
Display and record your current disk configuration information using the prtvtoc command, as shown here:

prtvtoc <raw disk device name>

How are the disk slices arranged? What disk geometry does it display?

3.
Now, follow these steps to look at your disk information using the format utility:

  1. Type format. The Main menu appears, displaying your disk drives. You're going to select the disk numbered 0, so note all of the information on that line.

  1. Type 0. This will select the first disk listed. The Format menu will appear.

  1. Type partition. The Partition menu will appear.

  1. Type print. All of your disk partition information will be displayed.

  1. Press Ctrl+D. You'll exit the format utility.


1.5. Creating a File System

The following exercise requires that you have a spare disk drive connected to your system or a spare, unused slice on a disk. You will practice creating a disk slice and creating a file system.

Estimated time: 30 minutes

1.
Practice creating a slice on your spare disk drive using the steps outlined in the earlier section titled "Using the format Utility to Create Slices."

2.
Create a file system on the new or unused slice using the newfs command as follows:

newfs <raw device name>

3.
Create a directory in the root partition named /test, as shown here:

mkdir /test

4.
Mount the new file system to support large files using the following command:

mount -o largefiles <block device name> /test

5.
Unmount the file system, as shown here:

umount /test

6.
View the contents of the /etc/vfstab file on your system by typing cat /etc/vfstab.

7.
Add the following line to the /etc/vfstab file for the file system you've just created so that it gets mounted automatically at boot time:

<raw device> <block device name> /test  ufs  2   yes  -

8.
Reboot the system:

/usr/sbin/shutdown -y -g0 -i6

9.
Verify that the file system was mounted automatically:

mount4p1

1.6. Tuning a File System

In this exercise, you'll modify some of the file system parameters that were specified when the file system was originally created with the newfs command.

Estimated time: 15 minutes

1.
Log in as root.

2.
List all of the parameters currently in use on the file system by typing the following:

newfs -v <raw device name>

3.
Open another window. Leave the information displayed in step 2 in the window for referencing later. In the new window, type the tunefs command to change the minfree value to 5% on the file system as follows:

tunefs -m5 <raw device name>

4.
View the new file system parameters, but this time you'll use the mkfs command as follows:

mkfs -m <raw device name>

Compare the parameters displayed with the parameters that were displayed earlier in the other window.

5.
Try the fstyp command for viewing the file system parameters as follows:

fstyp -v <raw device name>

1.7. Using Volume Manager

In this exercise, you'll utilize Volume Manager to automatically mount a CD-ROM.

Estimated time: 10 minutes

1.
Insert a CD-ROM into the CD-ROM player.

2.
Type the mount command with no options to verify that the device was mounted. What is the mount point that was used?

3.
Eject the CD-ROM as follows:

eject cdrom

4.
Type the following command to look for the Volume Manager process named vold:

pgrep -l vold

5.
Turn off the Volume Manager by typing the following:

/etc/init.d/volmgt stop

6.
Type the following command to look for the Volume Manager process named vold:

pgrep -l vold

7.
Insert the CD into the CD-ROM player. Did it mount the CD?

8.
Restart the Volume Manager daemon by typing the following:

/etc/init.d/volmgt start

9.
Type the mount command with no options to list all mounted file systems. Is the CD mounted now?

Exam Questions

1.

Which of the following represents the kernel's abbreviated name for every possible device on the system?

  1. Instance name

  1. Logical device

  1. Physical device name

  1. Pseudo device name


2.

Physical device files are found in which of the following?

  1. /kernel/drv

  1. /dev

  1. /platform

  1. /devices


3.

Which of the following displays device configuration information, including system hardware, pseudo devices, loadable modules, and selected kernel parameters?

  1. messages

  1. prtconf

  1. dmesg

  1. sysdef


4.

When you see the driver not attached message, it means which of the following?

  1. The device for this driver is not attached.

  1. A driver is unavailable for this device.

  1. No driver is currently attached to the device instance because there is no device at this node or the device is not in use.

  1. The kernel needs to be reconfigured to attach the device.


5.

The conf files reside in what file system?

  1. /kernel/drv

  1. /dev

  1. /devices

  1. /platform


6.

Which of the following are mapped to a physical device name in the /etc/path_to_inst file?

  1. Logical devices

  1. Instance names

  1. Physical devices

  1. Pseudo devices


7.

You can determine the mapping of an instance name to a physical device name by doing what? Choose all that apply.

  1. Looking at output from the dmesg command

  1. Viewing the /var/adm/messages file

  1. Looking at output from the sysdef command

  1. Looking at output from the prtconf command


8.

The system relies on information found in which of the following files to find the root, usr, or swap device?

  1. /etc/vfstab

  1. /etc/path_to_inst

  1. kernel

  1. /kernel/drv/

  1. /etc/driver


9.

Which of the following commands creates logical links to device nodes in the /dev and /devices directories?

  1. boot -r

  1. drvconfig

  1. devfsadm

  1. devlinks


10.

Which of the following commands is used to inform the system about newly installed device drivers?

  1. devlinks

  1. drvconfig

  1. add_drv

  1. devfsadm


11.

Which of the following is the daemon responsible for handling both reconfiguration boot processing and updating /dev and /devices in response to dynamic reconfiguration event notifications from the kernel?

  1. devfsadmd

  1. inetd

  1. devfsdadm

  1. svc.startd


12.

Your external CD-ROM was not turned on when the system was last booted with a reconfiguration reboot. To gain access to the CD-ROM, you could halt the system, turn on power to the CD-ROM, and start the system back up, or you could issue which of the following commands at the command prompt?

  1. drvconfig cdrom

  1. add_drv cdrom

  1. devfsadm

  1. drvconfig -d


13.

Which of the following indicates the general device driver for devices such as disk, tape, or serial line?

  1. Minor device number

  1. Major device number

  1. Device tree

  1. Pseudo device


14.

The minor device number:

  1. Indicates the general device driver for devices such as disk, tape, or serial line.

  1. Indicates the specific member within a driver.

  1. Uniquely defines a device and its device driver.

  1. Identifies the proper device location and device driver to the kernel.


15.

Logical device files in the /dev directory are symbolically linked to which of the following in the /devices directory?

  1. Instance names

  1. Pseudo device files

  1. Full device path names

  1. Physical device files


16.

Which of the following is a link from the /dev directory to the physical device name located in the /devices directory?

  1. Full device path name

  1. Pseudo device name

  1. Logical device name

  1. Instance name


17.

/dev/dsk/c0t0d0s7 is what type of device?

  1. Logical device name

  1. Pseudo device name

  1. Full device path name

  1. Instance name


18.

Which of the following commands creates entries in the /dev directory for disk drives attached to the system?

  1. devfsadm

  1. add_drv

  1. drvconfig

  1. boot -r


19.

Which directory contains the disk entries symbolically linked to the block device nodes in /devices?

  1. /kernel/drv

  1. /dev/rdsk

  1. /vol/dev/aliases

  1. /dev/dsk


20.

Which of the following best describes a physical device name?

  1. It represents the full device pathname of a device.

  1. It is equivalent to the SCSI target ID of a device.

  1. It represents the actual name of a device, such as a disk, tape, and so on.

  1. It represents the kernel's abbreviated name for a device on the system.


21.

In the standard device file naming convention "cXtYdZ," what does the "tY" portion of the filename identify?

  1. The controller card to which this device is attached

  1. The SCSI target address of the device

  1. The LUN of the device

  1. The function number as contained on the "Core I/O" board


22.

Which of the following is a character device name?

  1. /dev/dsk/c0t3d0s0

  1. /dev/rdsk/c0t3d0s0

  1. /dev/cua

  1. /devices/sbus@1,f8000000/esp@0,40000/sd@3,0:a


23.

What best describes an instance name?

  1. The kernel's abbreviated name for every possible device on the system

  1. A symbolic link to a physical device file

  1. The full device pathname of a device

  1. The SCSI address of a disk drive


24.

Logical devices are organized in subdirectories under which directory?

  1. /dev

  1. /devices

  1. /kernel

  1. /


25.

What best describes a logical device name?

  1. It is a symbolic link to a physical device file.

  1. It represents the kernel's abbreviated name for every possible device on the system.

  1. It represents the full device pathname of a device.

  1. It defines the SCSI address of a disk device.


26.

What statement is not true about disk slices on standard Solaris?

  1. Each slice can hold only one file system.

  1. A file system cannot span multiple disk slices.

  1. A file system cannot be increased or decreased.

  1. Slices can span multiple disks.


27.

Where is disk configuration information stored?

  1. On the disk label

  1. In several locations on the disk

  1. In the superblock

  1. In the partition table


28.

Which of the following stores the procedures used to boot the system?

  1. Boot block

  1. Superblock

  1. inode

  1. Disk label


29.

Which of the following commands will display partition information about a disk?

  1. prtvtoc

  1. sysdef

  1. df -k

  1. sysinfo


30.

Which of the following is not a virtual file system?

  1. /export/home

  1. Tmpfs

  1. Cachefs

  1. Procfs


31.

Which of the following tasks cannot be performed with the format utility?

  1. Repairing defective sectors

  1. Partitioning

  1. Retrieving corrupted disk labels

  1. Displaying disk usage


32.

Which of the following does the superblock not contain?

  1. Size and status of the file system

  1. Cylinder group size

  1. Pathname of the last mount point

  1. Boot information


33.

What information does the inode contain? Choose all that apply.

  1. The type of the file

  1. File directory information

  1. The number of bytes in the file

  1. Logical volume information


34.

What is not true about logical block sizes?

  1. The logical block size is the size of the blocks the Unix kernel uses to read or write files.

  1. By default, the logical block size is 8192 bytes.

  1. A larger logical block size increases efficiency for file systems in which most of the files are large.

  1. A small logical block size increases efficiency for file systems in which most of the files are large.


35.

What determines the number of inodes to be created in a new file system?

  1. The number of inodes depends on the amount of disk space that is allocated for each inode and the total size of the file system.

  1. 2048 inodes are created per 1GB of file system space.

  1. The number is dynamic and the kernel assigns inodes as required by the number of files in a file system.

  1. By default, one inode is allocated for each 2KB of data space.


36.

In Solaris, which of the following is referred to as the smallest allocable unit of disk space?

  1. Fragment

  1. Data block

  1. Logical block

  1. Byte


37.

What is another name for swap space and the total physical memory combined?

  1. Virtual memory

  1. Random Access Memory

  1. Partition C or Slice 2

  1. Static memory


38.

When should a file system be checked with fsck? Choose all that apply.

  1. If the file system was unmounted improperly

  1. After a power outage

  1. Whenever a file system cannot be mounted

  1. When data has been accidentally deleted


39.

What does fsck do when it preens a file system?

  1. Forces checking of the file system

  1. Checks and fixes the file system noninteractively

  1. Checks writeable file systems only

  1. Only checks to determine if a file system needs checking


40.

Which of the following files contains a list of file systems to be automatically mounted at bootup?

  1. /etc/fstab

  1. /etc/dfs/dfstab

  1. /etc/vfstab

  1. /etc/rc2.d/S74autofs


41.

The mountall command

  1. Mounts the CD-ROM and floppy automatically

  1. Mounts all file systems specified in the file system table

  1. Shares all files systems so that they can be mounted

  1. Mounts the tape in the tape drive


42.

What command(s) is/are used to display disk space information?

  1. du

  1. df

  1. quota

  1. repquota

  1. All of the above


43.

Which of the following mount options is used to mount file systems that have files larger than 2GB?

  1. largefiles

  1. nolargefiles

  1. lf

  1. nlf


44.

What should you do to disable UFS logging on a file system?

  1. Use the -o logging option with the mount command.

  1. Use the -l option with the mount command.

  1. You don't need to do anything; nologging is the default when mounting a file system.

  1. Use the logging feature in the newfs command when creating the file system.


45.

Which of the following represents the correct format for an entry in the /etc/vfstab file?

  1. device to mount, device to fsck, mount point, FS type, fsck pass, mount at boot, mount options

  1. device to fsck, device to mount, mount point, FS type, fsck pass, mount at boot, mount point

  1. mount point, device to mount, device to fsck, mount point, FS type, fsck pass, mount at boot

  1. mount point, device to fsck, device to mount, mount point, FS type, fsck pass, mount at boot


46.

Which of the following commands shows you the disk usage of each file in each subdirectory of a file system?

  1. du

  1. df

  1. ls

  1. printenv


47.

Which of the following commands displays disk space occupied by mounted file systems?

  1. df

  1. du

  1. ls

  1. printenv


48.

Which of the following causes high fragmentation?

  1. Creating large numbers of small files

  1. Creating large numbers of large files

  1. Not enough disk space

  1. A file's disk blocks being inefficiently scattered across the whole file system


49.

Output from df -k does not contain which of the following fields?

  1. Total size in kilobytes

  1. Fragmentation

  1. Capacity

  1. Kilobytes available


50.

Which of the following is the recommended way to create a file system?

  1. mkfs

  1. format

  1. tunefs

  1. newfs


51.

Which of the following commands do you use to write or display labels on unmounted disk file systems?

  1. format

  1. prtvtoc

  1. newfs

  1. labelit


52.

Which of the following commands do you issue to determine whether a file system is a UFS?

  1. fstyp

  1. prtvtoc

  1. format

  1. newfs -v


53.

Which of the following commands is used to change the minfree value of a file system?

  1. mkfs

  1. tunefs

  1. newfs

  1. format


54.

Which of the following commands do you use to view a full listing of file system parameters?

  1. fstyp

  1. mkfs

  1. newfs

  1. prtvtoc


55.

A large file is a regular file whose size is greater than or equal to which of the following?

  1. 1TB

  1. 1GB

  1. 5GB

  1. 2GB


56.

Which of the following commands is not large fileaware?

  1. labelit

  1. vi

  1. mkfs

  1. mount


57.

Which of the following types of utility is able to handle large files as input and to generate large files as output?

  1. Large filecompatible

  1. Large filesafe

  1. Large fileaware

  1. Large filecapable


58.

Which of the following options to the mount command provides total compatibility with previous file system behavior, enforcing the 2GB maximum file size limit?

  1. -o compat

  1. largefiles

  1. -nolargefiles

  1. -o nolargefiles


59.

Which of the following options do you type the mount command with to display a list of mounted file systems in /etc/vfstab format?

  1. -p

  1. -v

  1. -f

  1. -a


60.

Which of the following examples uses the mount command to map a directory to a file system as read/writeable, disallow setuid execution, and enable the creation of large files:

  1. mount -o rw,nosuid,large /dev/dsk/c0t0d0s0 /home2

  1. mount -o rw,nosuid,largefiles /dev/dsk/c0t0d0s0 /home2

  1. mount -o rw,nosuid,largefiles /dev/rdsk/c0t0d0s0 /home2

  1. mount -o rw,suid,largefiles /dev/dsk/c0t0d0s0 /home2


61.

When a file system is mounted, where are entries maintained?

  1. /etc/mnttab

  1. /etc/vfstab

  1. /etc/fstab

  1. /mnt


62.

Which of the following tasks can be performed on a mounted file system?

  1. labelit

  1. fsck

  1. tunefs

  1. newfs


63.

If something is causing the file system to be busy, which of the following commands can you use to list all the processes accessing the file system?

  1. fuser

  1. mount

  1. ps

  1. finger


64.

Which of the following commands stops all processes that are using the /home2 file system?

  1. fuser -c -k /home2

  1. fuser -k /home2

  1. kill -9 /home2

  1. umount /home2


65.

Which of the following is the mechanism that manages removable media, such as the CD-ROM and floppy disk drives?

  1. autofs

  1. NFS

  1. vold

  1. init


66.

vold does all of the following except for what?

  1. Gives other systems on the network automatic access to any disks and CDs the users insert into your system

  1. Automatically mounts disks and CDs

  1. Enables the user to access disks and CDs without having to be logged in as root

  1. Automatically mounts a file system located on another system when that file system is accessed


67.

Which of the following is the directory that provides character device access for the media in the primary floppy drive?

  1. /vol/dev/diskette0

  1. /dev/rdiskette

  1. /vol/dev/aliases/floppy0

  1. /floppy/floppy0


68.

Which of the following contains the volume management configuration information used by vold?

  1. /etc/init.d/volmgt

  1. /etc/vfstab

  1. /etc/vold.conf

  1. /etc/inittab


69.

Which of the following files can the system administrator modify to specify the program that should be called if media events happen, such as eject or insert?

  1. /etc/vold.conf

  1. /etc/rmmount.conf

  1. /etc/inittab

  1. /etc/mnttab


70.

Which of the following actions notifies the user if an attempt is made to access a CD or disk that is no longer in the drive?

  1. vold

  1. volcheck

  1. volmissing

  1. rmmount


71.

Which of the following commands is used to format a floppy disk and add a volume label?

  1. format -d

  1. labelit

  1. format

  1. fdformat


72.

Which of the following should you issue to stop the volume management daemon?

  1. vold stop

  1. /etc/init.d/volmgt stop

  1. ps -ef|grep vold, then kill the process ID for vold

  1. volcancel


73.

Which of the following commands displays capacity information on each mounted file system?

  1. du

  1. format

  1. prtvtoc

  1. df


74.

Which of the following commands is used to instruct the system to mount the floppy automatically?

  1. volcheck

  1. vold

  1. mount

  1. automount


75.

You can type mount /opt on the command line and not get an error message if which of the following conditions exits?

  1. /opt is listed in the /etc/rmtab.

  1. /opt is listed in the /etc/mnttab.

  1. /opt is listed in the /etc/vfstab.

  1. /opt is listed in the /etc/dfs/dfstab.


76.

Volume Manager provides access to the CD-ROM and floppy devices through which of the following directories?

  1. /vol/dev

  1. /dev/vol

  1. /dev

  1. /vold


77.

Which of the following is not true about volume management?

  1. Volume Manager is started via the /etc/init.d/volmgt script.

  1. Volume Manager automatically mounts CDs and floppy disks.

  1. Volume Manager reads the /etc/vold.conf configuration file at startup.

  1. Volume Manager automatically checks and performs an fsck on file systems at bootup.


78.

Which directory contains configuration files used to define a machine's identity?

  1. /dev

  1. /usr

  1. /etc

  1. /opt

  1. /var


79.

Which type of link cannot span file systems?

  1. Symbolic link

  1. Hard link

  1. Hardware link

  1. Software link


80.

Which type of link can point to a file that does not exist?

  1. Symbolic link

  1. Hard link

  1. Hardware link

  1. Software link


81.

You can remove a link using which of the following commands?

  1. unlink

  1. rm

  1. rmdir

  1. rm -1

  1. rmlink


82.

Which task cannot be performed by the SMC Disks Tool?

  1. View partition information.

  1. Format a disk.

  1. Partition a disk.

  1. Copy one disk's partition scheme to another disk.


Answers to Review Questions

1.

A. The instance name represents the kernel's abbreviation name for every possible device on the system. For more information, see the "Device Drivers" section.

2.

D. Physical device files are found in the /devices directory. For more information, see the "Physical Device Name" section.

3.

D. The sysdef command displays device configuration information, including system hardware, pseudo devices, loadable modules, and selected kernel parameters. For more information, see the "Physical Device Name" section.

4.

C. When you see the driver not attached message, it means no driver is currently attached to the device instance because there is no device at this node or the device is not in use. For more information, see the "Physical Device Name" section.

5.

A. The .conf files reside in the /kernel/drv directories. For more information, see the "Device Autoconfiguration" section.

6.

B. Instance names are mapped to a physical device name in the /etc/path_to_inst file. For more information, see the "Instance Names" section.

7.

A, B. You can determine the mapping of an instance name to a physical device name by looking at the dmesg output and by viewing the /var/adm/messages file. For more information, see the "Instance Names" section.

8.

A, B. The system relies on information found in both the /etc/vfstab file and the /etc/path_to_inst file to find the root, usr, and swap device. For more information, see the "Instance Names" section.

9.

C. The devfsadm command a creates logical links to device nodes in /dev and /devices and loads the device policy. For more information, see the "Instance Names" section.

10.

D. The devfsadm command is used to inform the system about newly installed device drivers. For more information, see the "Instance Names" section.

11.

A. The devfsadmd daemon is the daemon responsible for handling both reconfiguration boot processing and updating /dev and /devices in response to dynamic reconfiguration event notifications from the kernel. For more information, see the "Instance Names" section.

12.

C. An example of when to use the devfsadm command would be if the system has been started, but the power to the CD-ROM or tape drive was not turned on. During startup, the system did not detect the device; therefore, its drivers were not installed. The devfsadm command will perform these tasks. For more information, see the "Instance Names" section.

13.

B. The major device number indicates the general device driver for devices such as disk, tape, or serial line. For more information, see the "Major and Minor Device Numbers" section.

14.

B. The minor device number indicates the specific member within a driver. For more information, see the "Major and Minor Device Numbers" section.

15.

D. The logical device name is a link from the /dev directory to the physical device name located in the /devices directory. For more information, see the "Logical Device Name" section.

16.

C. The logical device name is a link from the /dev directory to the physical device name located in the /devices directory. For more information, see the "Logical Device Name" section.

17.

A. The logical device name is a link from the /dev directory to the physical device name located in the /devices directory. The following is an example of a logical device name: /dev/dsk/c0t0d0s7. For more information, see the "Logical Device Name" section.

18.

A. The devfsadm command can be used to create entries in the /dev directory for disk drives attached to the system. For more information, see the "Instance Names" section.

19.

D. The /dev/dsk directory contains the disk entries for the block device nodes in /devices. For more information, see the "Block and Raw Devices" section.

20.

A. A physical device name represents the full device pathname of the device. Physical device files are found in the /devices directory and have the following naming convention:

/devices/sbus@1,f8000000/esp@0,40000/sd@3,0:a

For more information, see the "Physical Device Name" section.

21.

B. The fields of the logical device name cXtYdZ are as follows:

  • cXRefers to the SCSI controller number

  • tYRefers to the SCSI bus target number

  • dZRefers to the disk number (always 0, except on storage arrays)

For more information, see the "Logical Device Name" section.

22.

B. In the character device name /dev/rdsk/c0t3d0s0, the /rdsk directory refers to the character or raw device file. The r in rdsk stands for raw. For more information, see the "Block and Raw Devices" section.

23.

A. The instance name represents the kernel's abbreviated name for every possible device on the system. For example, sd0 and sd1 represent the instance names of two SCSI disk devices. For more information, see the "Instance Names" section.

24.

A. Logical device names are used with most Solaris file system commands to refer to devices. Logical device files in the /dev directory are symbolically linked to physical device files in the /devices directory. For more information, see the "Logical Device Name" section.

25.

A. Logical device files in the /dev directory are symbolically linked to physical device files in the /devices directory. For more information, see the "Logical Device Name" section.

26.

D. On a standard Solaris file system, a file system cannot span multiple disks or slices. It's only possible when using virtual file systems (that is, Solaris Volume Manager). For more information, see the "Disk Slices" section.

27.

A. Disk configuration information is stored on the disk label. For more information, see the "Displaying Disk Configuration Information" section.

28.

A. The boot block stores the procedures used in booting the system. Without a boot block, the system does not boot. For more information, see the "Components of the UFS" section.

29.

A. The slice information for a particular disk can be viewed by using the prtvtoc command. For more information, see the "Disk Slices" section.

30.

A. The following are virtual file systems: swapfs, procfs, lofs, cachefs, tmpfs, and mntfs. For more information, see the "Virtual File Systems" section.

31.

D. The format utility is used to retrieve corrupted disk labels, repair defective sectors, format and analyze disks, partition disks, and label disks. For more information, see the "Using the format Utility to Create Slices" section.

32.

D. Here are a few of the more important things contained in a superblock:

  • Size and status of the file system

  • Label (file system name and volume name)

  • Size of the file system's logical block

  • Date and time of the last update

  • Cylinder group size

  • Number of data blocks in a cylinder group

  • Summary data block

  • File system state (clean, stable, or active)

  • Pathname of the last mount point

For more information, see the "The Superblock" section.

33.

A, C. An inode contains all of the information about a file except its name, which is kept in a directory. The inode information is kept in the cylinder information block and contains the following:

  • The type of the file (regular, directory, block special, character special, link, and so on)

  • The mode of the file (the set of read/write/execute permissions)

  • The number of hard links to the file

  • The user id of the file's owner

  • The group id to which the file belongs

  • The number of bytes in the file

  • An array of 15 disk-block addresses

  • The date and time the file was last accessed

  • The date and time the file was last modified

  • The date and time the file was created

For more information, see the "The inode" section.

34.

D. As a general rule, a larger logical block size increases efficiency for file systems in which most of the files are large. Use a smaller logical block size for file systems in which most of the files are small. For more information, see the "Logical Block Size" section.

35.

A. The number of inodes depends on the amount of disk space that is allocated for each inode and the total size of the file system. For more information, see the "The inode" section.

36.

A. The file system fragment size is the smallest allocable unit of disk space, which by default is 1024 bytes. For more information, see the "Information on File Systems" section.

37.

A. Swap space plus the total amount of physical memory is also referred to as virtual memory. For more information, see the "Virtual File Systems" section.

38.

A, B, C. fsck should be run after a power outage, when a file system is unmounted improperly, or whenever a file system cannot be mounted. For more information, see the "Repairing File Systems" section.

39.

B. Normally, fsck is run noninteractively at bootup to preen the file systems after an abrupt system halt. Preening automatically fixes any basic file system inconsistencies and does not try to repair more serious errors. While preening a file system, fsck fixes the inconsistencies it expects from such an abrupt halt. For more serious conditions, the command reports the error and terminates. For more information, see the "Repairing File Systems" section.

40.

C. The /etc/vfstab file contains a list of file systems to be automatically mounted when the system is booted to the multiuser state. For more information, see the "Creating an Entry in the /etc/vfstab File to Mount File Systems" section.

41.

B. The mountall command mounts all file systems specified in the file system table (vfstab). For more information, see the "Mounting File Systems" section.

42.

E. The following commands can be used to display disk space usage: du, df, quota, repquota. For more information, see the "Displaying a File System's Disk Space Usage" section.

43.

A. The largefiles mount option lets users mount a file system containing files larger than 2GB. For more information, see the "Mounting File Systems" section.

44.

A. Use the -o nologging option of the mount command to disable UFS logging on a file system. Logging is the default. For more information, see the "Mounting File Systems" section.

45.

A. The correct format for the /etc/vfstab file is as follows:

device to mount, device to fsck, mount point, FS type, fsck pass, mount at boot, mount options.

For more information, see the "Creating an Entry in the /etc/vfstab File to Mount File Systems" section.

46.

A. Use the du (directory usage) command to report the number of free disk blocks and files. For more information, see the "Displaying a File System's Disk Space Usage" section.

47.

A. The df command with no options lists all mounted file systems and their device names. It also lists the total number of 512-byte blocks used and the number of files. For more information, see the "Displaying a File System's Disk Space Usage" section.

48.

A. Typically, creating large numbers of small files causes high fragmentation. The solution is to either create a larger file system or to decrease the block size (finer granularity). For more information, see the "Displaying a File System's Disk Space Usage" section.

49.

B. The df -k command does not display the percentage of fragmentation. For more information, see the "Displaying a File System's Disk Space Usage" section.

50.

D. newfs is the friendly front end to the mkfs command. The newfs command automatically determines all the necessary parameters to pass to mkfs to construct new file systems. newfs was added in Solaris to make the creation of new file systems easier. It's highly recommended that the newfs command be used to create file systems. For more information, see the "Creating a UFS" section.

51.

D. After you create the file system with newfs, you can use the labelit utility to write or display labels on unmounted disk file systems. For more information, see the "Creating a UFS" section.

52.

A. Use the fstyp command to determine a file system type. For example, use it to check whether a file system is a UFS. For more information, see the "The fstyp Command" section.

53.

B. Use the tunefs command to change the minfree value of a file system. For more information, see the "Tuning File Systems" section.

54.

A. Use the fstyp command to view file system parameters. Use the -v option to obtain a full listing of a file system's parameters. For more information, see the "The fstyp Command" section.

55.

D. A large file is a regular file whose size is greater than or equal to 2GB. For more information, see the "Mounting a File System with Large Files" section.

56.

B. A utility is called large fileaware if it can process large files in the same manner that it does small files. A large fileaware utility can handle large files as input and can generate large files as output. The vi command is not large fileaware. For more information, see the "Mounting a File System with Large Files" section.

57.

C. As stated in the previous question and answer, a utility is called large fileaware if it can process large files in the same manner that it does small files. A large fileaware utility can handle large files as input and can generate large files as output. For more information, see the "Mounting a File System with Large Files" section.

58.

D. The -o nolargefiles option of the mount command provides total compatibility with previous file system behavior, enforcing the 2GB maximum file size limit. For more information, see the "Mounting a File System with Large Files" section.

59.

A. Type the mount command with the -p option to display a list of mounted file systems in /etc/vfstab format. For more information, see the "Creating an Entry in the /etc/vfstab File to Mount File Systems" section.

60.

B. The following command uses the mount command to map a directory to a file system as read/writeable, disallow setuid execution, and enable the creation of large files (more than 2GB in size):

mount -o rw,nosuid,largefiles /dev/dsk/c0t0d0s0\

/home2

For more information, see the "Mounting a File System with Large Files" section.

61.

A. When a file system is mounted, an entry is maintained in the mounted file system table called /etc/mnttab. This file is actually a read-only file system and contains information about devices that are currently mounted. For more information, see the "Mounting File Systems" section.

62.

C. D. Do not use the following commands on a mounted file system: fsck, and labelit. newfs cannot be run on a mounted file systemit generates an error. For more information, see the "Unmounting a File System" section.

63.

A. If something is causing the file system to be busy, you can use the fuser command to list all of the processes accessing the file system and to stop them if necessary. For more information, see the "The fuser Command" section.

64.

A. The following command stops all processes that are using the /home2 file system by sending a SIGKILL to each one: fuser -c -k /home2. For more information, see the "The fuser Command" section.

65.

C. The vold daemon is the mechanism that manages removable media, such as the CD-ROM and floppy disk drives. For more information, see the "Volume Management" section.

66.

D. vold does not automatically mount a file system located on another system when that file system is accessed. The facility responsible for that task is AutoFS. For more information, see the "Volume Management" section.

67.

B. /dev/rdiskette and /vol/dev/rdiskette0 are the directories providing character device access for the medium in the primary floppy drive, usually drive 0. For more information, see the "Volume Management" section.

68.

C. vold reads the /etc/vold.conf configuration file at startup. The vold.conf file contains the Volume Manager configuration information used by vold. For more information, see the "Volume Management" section.

69.

A. The "Actions" section of the vold.conf file specifies which program should be called if a particular event (action) occurs such as eject or insert. For more information, see the "Volume Management" section.

70.

C. The volmissing action in the vold.conf file notifies the user if an attempt is made to access a CD or diskette that is no longer in the drive. For more information, see the "Volume Management" section.

71.

D. Use the fdformat command to format a floppy disk, and then add a volume label. For more information, see the "Troubleshooting Volume Manager" section.

72.

B. Run the following run control script to stop the volume management daemon: /etc/init.d/volmgt stop. For more information, see the "Troubleshooting Volume Manager" section.

73.

D. The df command gives you capacity information on each mounted file system. For more information, see the "Displaying a File System's Disk Space Usage" section.

74.

A. The volcheck command instructs vold to look at each device and determine if new media has been inserted into the drive. The system administrator issues this command to check the drive for installed media. By default, it checks the drive to which /dev/diskette points. For more information, see the "Volume Management" section.

75.

C. You can type mount /opt on the command line and not get an error message if /opt is listed in the /etc/vfstab file. For more information, see the "Creating an Entry in the /etc/vfstab File to Mount File Systems" section.

76.

A. Volume Manager provides access to the floppy disk and CD-ROM devices through the /vol/dev directory. For more information, see the "Volume Management" section.

77.

D. Volume management does not automatically fsck file systems at bootup. It does, however, automatically mount CD-ROM and file systems when removable media containing recognizable file systems are inserted into the devices. For more information, see the "Volume Management" section.

78.

C. The /etc directory contains configuration files that define a system's identity. For more information, see the "The Root (/) File System" section.

79.

B. A hard link cannot span file systems, but a symbolic link can. For more information, see the "Hard Links" section.

80.

A. An advantage of a symbolic link over a hard link is that you can create a symbolic link to a file that does not yet exist. For more information, see the "Soft (Symbolic) Links" section.

81.

B. Remove a link using the rm command. For more information, see the "Soft (Symbolic) Links" section.

82.

B. The SMC Disks Tool cannot be used to format a disk. For more information, see the " Using the Solaris Management Console Disks Tool" section.


Previous Page
Next Page